CREDIT_CARDS Disruption

Incident Report for Blessing Transport Service

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 12:14 WIB

Update

We are continuing to investigate this issue.
Posted Apr 10, 2025 - 11:28 WIB

Investigating

We have detected a disruption in CREDIT_CARDS payments due to disruption on our partner.

You will experience an intermittent disruption and potentially won't be able to perform 3DS authentication transactions during this period.
Posted Apr 10, 2025 - 11:25 WIB
This incident affected: Web - Payment.